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IP Configuration of the AMC
Using AmcIPConfig

IP Configuration of the AMC

Starting the AmcIpConfig application
The application AmcIpConfig.exe finds and, if desired, configures AMC modules in the network. The names and/or IP
Addresses of the AMCs are necessary to parametrize these devices in the access control system. AMCs can be
password-protected to prevent unauthorized access.
AmcIpConfig.exe is launched differently, depending on the access control system:

Access Personal Edition
Start > Programs > Access Personal Edition > AMC IP-Configuration

Access Engine
In the BIS Configuration Browser the application can be found in the Tools menu under ACE Configuration AMC IP
Adresses

The AmcIpConfig.exe executable can be copied to and started from any PC in the system in
order to configure AMCs locally. A prerequisite is that .NET 1.1 be installed on the PC.
After a standard installation the application will be found at the following locations:
Access Personal Edition:
C:\Programs\BOSCH\Access Personal Edition\PE\bin
Access Engine:
C:\MgtS\Access Engine\AC\bin
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Menu and tool bar
The application makes its functions available via toolbar buttons and menus.
The following table gives an overview of the available functions.

Menu >
Function

Button

Description

File >
Options

To check or change the application settings.

File > Exit

Stops the application and closes the window.

Devices >
Scan

Starts the network search for AMCs.
During the scan the icon changes to

Devices >
Scan with
password...

, which can be clicked to abort the scan.

After entering a password starts the network search .
During the scan the icon changes to

, which can be clicked to abort the scan.

Devices >
Set IP...

This function is only available if exactly one non-protected list entry is selected.

Devices >
Upgrade
firmware...

This function is only available if at least one non-protected list entry is selected.

Help >
Contents
Help >
About
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Opens a dialog to set or change the network name and IP address of an AMC.

Opens a separate dialog to upgrade the firmware of the AMCs.
Opens this Online Help.
Opens an information box about the application version.
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File > Options
This dialog provides two settings

•

Cold start device before downloading

•

Device scan timeout [s]

The Cold start device before downloading option makes sure the device is running the
bootloader before downloading new firmware.
It is recommended that this option remain enabled.
The Device scan timeout option allows the user to select a scan timeout between 0.5 and 120
seconds (default = 5). Increasing this value enables the application to detect devices that
respond slowly to requests, due to a busy network.
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Scanning

IP Configuration of the AMC

Hide all drop-down text | Print

all text

Show all drop-down text | Print

all text

Scanning the Local Area Network for AMC Devices
To scan your local area network for available AMC devices, click the Scan symbol
Menu:Devices > Scan. (For an explanation of > Scan with Password... see below).
Show/Hide screen shot
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in the toolbar or select

IP Configuration of the AMC

The application scans your local area network for all available AMC devices and displays their MAC addresses, stored IP
addresses, DHCP status, IP address, device name, and serial number. Each AMC found is marked in the leftmost column
in one of the following ways:
<no mark>

password matched, or device not password-protected
password-protected (see below)
Device changed and requiring rescan

Scanning password-protected devices.
If you wish modify a password-protected AMC, click Scan with password&ldots; instead of Scan. You must then enter
the password for the AMC.

Scans are limited to within a single subnet.
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Hide all drop-down text | Print

all text

Show all drop-down text | Print

all text
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Configuring the AMC Ethernet Interface
IP Configuration of the AMC

Structure of the configuration dialog
AMCs which are not yet configured, or which require editing, can be selected (only singly) from the list.

The configuration dialog can be opened via the menu function Devices > Set IP... or via the
becomes active when an AMC is selected) or by double-clicking the desired list entry.

Network name

button (which

The dialog gives each new devices in a standard name consisting of the device type
(AMC) plus the last 8 digits of the serial number divided into two groups of four. [Version
00.44 or higher takes the last six digits of the MAC address.]
For more human-friendly identification the name can be replaced here by a unique string
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of maximum 14 characters.

Use only alphanumeric characters plus the separator "-"
(minus or dash)
The network name has to start with a letter. Do not use
special characters or spaces.
The names are not case sensitive.

Serial number

Can not be modified

MAC address

Can not be modified

Obtain address via
DHCP

If this box is checked an IP address can be obtained from a DHCP-Server, provided one
is available in the network.
Depending on the network the assignment and display of a DHCP IP address can take
some hours.

Use a fixed address

If static addresses are to be used instead, e.g. if no DHCP server is available, then this
option should be checked.

Stored IP address

Enter the static address here. This text field is only writable when the option Use a fixed
address has been checked. IP addresses consist of 4 decimal numbers between 0 and
255, separated by periods (".")

Enable subnets

This option activates the input fields Subnet mask and Default gateway.
This check box only becomes writable where the AMC's firmware permits these settings,
otherwise it is marked with a

Subnet mask

Enter the subnet mask number here.
Like IP addresses subnet masks consist of 4 decimal numbers between 0 and 255,
separated by periods ("."). However only the values 255 and 0 are used.

Default gateway

Enter the address of the default gateway here.
Gateways are routers in the same network. They serve to route data to other parts of the
network or internet.

Port

10001 (= default)
Port is an address component for assigning data to the correct protocol. Port numbers
range between 1 and 65534

Password

Every configurable AMC can be protected by a password of max. 8 characters. If
scanned without a valid password a password-protected AMC will become unreachable.

Confirm password

Confirm the chosen password here.
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Use of the configuration dialog
Existing entries can be removed from their respective fields using the
Invalid or incomplete entries are marked with a

buttons.

to the right of their respective fields

Mousing over these marking produces a "tooltip" which explains more fully the cause of the problem. The following table
presents an overview of possible tooltips.
Network
name

Stored IP

9

AMC-IP-Config_EN

address

Enable
subnets

Subnet
mask

Default
gateway

Port

Confirm
password
The OK button will not become clickable until all entered data have been corrected.

A modified device is specially marked with a
. This marking remains in place until a
subsequent scan verifies the correctness of the modifications and removes the marking. It is
not possible to modify devices while the marking is shown.
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Upgrade
Upgrading the firmware
The AmcIpConfig makes it possible to update the bootloader firmware of the AMC, change various device settings and
secure access to the device.
Follow the steps described below to upgrade the AMC firmware.
1.

Before the firmware of a device can be changed, the user has to select the devices that need to be upgraded.
By selecting the Scan button the application will start searching for AMC devices in the network. When the
application detects AMCs, they will be added to the list of devices.
a.

The scan will end after a fixed amount of time (default: 5 seconds), but this value can be changed in
the options dialog.

Ensure that the option Cold start device before downloading is activated.

2.

As soon as devices are available in the list, the user can select one or more non-protected devices for
upgrading. When the appropriate devices have been marked, the
upgrade.

button can be selected to start the

Show/Hide screen shot

3.

The upgrade dialog provides a wizard interface that will guide the user through the upgrade process.
a.

The upgrade process can always be stopped by closing the dialog with the x button in the title bar or
pressing Cancel.

b.

Pressing Next will always continue to the following upgrade step in the process

c.

Pressing Back will return to the previous step.
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4.

On the first page of the dialog, a warning is displayed to the effect that the device should be disconnected from
the access control system during upgrade and that the upgrade should never be interrupted e.g. by loss of
power supply, lest incomplete firmware render the device unusable.
Show/Hide screen shot

5.

After clicking Next, the user can select the firmware to program into the device. A list is shown with the devices
the user selected after the device scan. As far as the devices support it, their version is displayed. For older
devices only the version of the currently active application can be shown. The last column displays the new
firmware that will be programmed into the device (or no upgrade, if no firmware is selected).
Show/Hide screen shot
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6.

Select the device to upgrade, again.

7.

Click the ellipsis button (...), select the firmware to upgrade and click Open.
Show/Hide screen shot
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Upgrades overwrite the AMC software. If the upgrade fails, the device will no longer function
and must be reset by a service engineer.

Different firmware versions can be installed on different devices if necessary. Repeat steps 6
and 7 for each device.
The upgrade for a device can be averted by selecting the device and pressing the Don’t
upgrade button. As long as an upgrade is selected for at least one device the Upgrade
button will be enabled.

Show/Hide screen shot
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8.

By pressing the Upgrade button, the update of the devices will start.
a.

The application will display the progress of the update for each device. The normal process steps are:

•

Device coldstart

•

Downloading

•

Verifying new version

•

Verifying communication

•

Upgrade successful

Show/Hide screen shot
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9.

By clicking Finish the dialog will be closed.

10. Changed devices are marked
Show/Hide screen shot

11. Devices marked as changed can not be re-edited. Rescan the AMCs to remove the change mark and thus
enable further modification.

16

IP Configuration of the AMC

17

AMC-IP-Config_EN

Saving
Saving list contents
Scan results can be saved for the purposes of documentation, editing, printing etc. Use the key combination Ctrl+C to
copy the list to the clipboard, and then Ctrl+V to paste the clipboard into a text editor.

If the text appears not as above but in one continuous line, then set your text editor to
recognize line feeds. E.g. In the Notepad editor Menu:Format > Word Wrap.
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Hide all drop-down text | Print

all text

Show all drop-down text | Print

all text

AMC Status Display
During operation, the LCD display shows information about the AMC's status. Push the Dialog button to switch between
the different modes.
Show/Hide button location

The currently set display mode remains until the next operation of the Dialog button.

Push

Display

0

V00.35 02.05.05
or

Description
Software version and date of the downloader
every 5 sec. alternating with the display of the reader interface.

WIEGAND or LBUS or
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BG900
1

99999876543210 A

(= default page)
BOSCH serial number and bus address
A = address 1
B = address 2
C = address 3
D = address 4
E = address 5
F = address 6
G = address 7
H = address 8

2

02.05 15:35:15 (S)

Current date and time.
(S) = Summer time and (W) = Winter time

3

Dig. I0: 

Display of the digital contacts: connected input signals will be shown as dots
above the dotted mid-line, connected outputs as dots below.

3a

Dig. I1: 

If any extension boards are connected, their input and output signals will be
displayed analogously on additional "pages".

3b

Dig. I2: 

3c

Dig. I3: 

4

MAC 0010174C8A0C

MAC address

5

N AMC-1234-5678

Network name

6

I 192.168.10.18

IP address of the AMC

7

G 192.168.10.255

IP address of the gateway
(Version V 00.44 or higher)

8

M 255.255.255.0

Subnet mask
(Version V 00.44 or higher)

9

H 192.168.10.10

IP address of the host

10

DHCP 1

DHCP
1 = on
0 = off

11

D 192.168.10.1

IP address of the DNS server

12

Host: - "C"

Host activity,
+ = online
- = offline
"C" = Counter of the received data packages from the host interface.
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Hide all drop-down text | Print

all text

Show all drop-down text | Print

all text
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